Problema

Después de instalar neoStampa, algunos usuarios pueden experimentar un comportamiento inusual que bloquea los procesos de neoStampa.


Posibles síntomas

  • Al instalar neoStampa, puede aparecer un mensaje de advertencia durante el proceso.


  • Al intentar eliminar el controlador del plotter actual, aparece un mensaje que indica que el documento actual debe estar cerrado, aunque no haya ningún documento abierto.


  • Al salir de neoStampa, aparecen dos alertas consecutivas:
    • Exception - 16100 (?) in module [?).


    • Error -5: unable to save server status.



  • neoStampa o las aplicaciones relacionadas no pueden guardar archivos en Usuarios/Público/Documentos públicos. Esto puede afectar a las calibraciones del esquema, los archivos de registro y otros archivos generados.


  • El servicio neoControl intenta iniciarse repetidamente, pero falla.



Causa

Estos problemas suelen estar causados por la protección contra ransomware de Windows (acceso controlado a carpetas), que impide que neoStampa escriba en directorios protegidos. Esta función de seguridad está diseñada para evitar que aplicaciones no autorizadas puedan escribir ningún tipo de datos.



Solución

1. Desactive la protección contra ransomware (para realizar pruebas)

  1. Abra Seguridad de Windows.
  2. Vaya a Protección contra virus y amenazas.
  3. Abra Protección contra ransomware.
  4. Busque Acceso controlado a carpetas.
  5. Desactívelo temporalmente (Off).

Vuelva a probar neoStampa y compruebe que los problemas ya no se producen.




2. Permitir neoStampa como aplicación autorizada.

Si desea mantener habilitada la protección contra ransomware:

  1. Vaya a Seguridad de Windows → Protección contra virus y amenazas → Protección contra ransomware.
  2. Abra Permitir una aplicación a través del acceso controlado a carpetas.
  3. Añada los ejecutables de neoStampa a la lista de permitidos.